Help finding the cause of the white space?

Discuss general web development questions. Help others and get help from others.

Moderator: kfury77

Help finding the cause of the white space?

Postby Mary303 » Tue Jun 09, 2009 4:25 pm

First note ... this is the only coding product I've ever used, I'm a newbie at it. WeBuilder has worked very well for me.

This link is to a form I'm building that I could use some help with. I must have a code error but I cannot find it. Trying to get rid of the white space between the header and the input boxes (you have to scroll down to see them.)
http://www.barntalk.modelhorseblab.com/ ... formL.html

Also ... the email functionality is being provided by my server host, HostGator. I don't know if anyone here will be able to help, but the email button at the bottom does not work online for me. It does for HG support, who say everything is set up properly and working normally for them. I did get their test submission emails. Any advice on why the email button isn't working for me, if you think it is working, and how I can test it, is much appreciated!

Thanks!
Mary303
 
Posts: 7
Joined: Wed May 20, 2009 5:47 am

Re: Help finding the cause of the white space?

Postby syrupcore » Wed Jun 10, 2009 8:25 am

try changing the opening table tag to <table cellspacing="0" cellpadding="0" border="0">
User avatar
syrupcore
Top Contributor
 
Posts: 917
Joined: Thu Jul 21, 2005 12:58 am
Location: Portland, Oregon, usa

Re: Help finding the cause of the white space?

Postby davenz » Tue Jun 16, 2009 12:46 pm

Mary303 wrote:First note ... this is the only coding product I've ever used, I'm a newbie at it. WeBuilder has worked very well for me.

Also ... the email functionality is being provided by my server host, HostGator. I don't know if anyone here will be able to help, but the email button at the bottom does not work online for me. It does for HG support, who say everything is set up properly and working normally for them. I did get their test submission emails. Any advice on why the email button isn't working for me, if you think it is working, and how I can test it, is much appreciated!

Thanks!


The form doesn't work because as far as I can see your settings are wrong. You need to have the whole thing enclosed in just one form tag, not each section in their own form tags. The single form tag should have an action assigned to it; your code shows the original code from HostGator

<!-- ORIGINAL CODE from HostGator
<form action="http://www.mydomain.com/cgi-sys/formmail.pl" method="post">
<input type="hidden" name="recipient" value="youremail@here.com">
<input type="hidden" name="subject" value="FormMail E-Mail">
Whatever you want to say here<br /><br />
<input type="text" name="email" size="20" value="Visitor E-Mail"><br />
<input type="text" name="tellme" size="20" value="E-Mail Content"><br /><br />
<input type="submit" name="submit" value="E-Mail Me!">
<input type="hidden" name="redirect" value="http://yourdomain.com/redirecto.html">
</form>

Your own form has to be configured to use the above snippet to call the formmail.pl script (which should already be set up in the cgi-bin folder on your host server). The code above needs to be reconfigured with your own domain name instead of 'mydomain.com' and all the other relevant settings. Get this wrong and you could provide a potential security risk so read the readme files your host should provide to get it set up properly.

Dave.
davenz
 

Re: Help finding the cause of the white space?

Postby ajmaske » Tue Jun 23, 2009 9:54 pm

look familiar ...

Code: Select all
<!--input sender information-->
<br><br>

<br><br>
<div>
testdiv
testtbl
testtr1

<br><br>
<br><br>
<br><br>
<br><br>
<br><br>
<br><br>
<br><br>
<br><br>
<br><br>
<br><br>


If you view source on your page... you've got all these <br>'s between the header and the <table> with your <input> boxes ... :D

Just read the rest of your post... If the form is not sending the email check the perl script in the <form action="">; perhaps there is a configuration setting you've missed...
Anthony
ajmaske
 
Posts: 38
Joined: Fri Jun 01, 2007 4:15 am
Location: Modesto, CA


Return to Web Developer Talk

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron