Button image not appearing

Post your questions and problem reports here.

Button image not appearing

Postby anitag » Wed Feb 23, 2011 10:58 am

Hi
I'm loving this software, yet I'm failing at the final hurdle - I can't see the images on my site. Really hoping some kind soul will help...

What I do:
-created a test button
-Insert into web page > just HTML code
- Select folder for the files: C:\Users\Nita\Desktop\TEST
-select "I will put the files in a *directory* relative.." Directory name: images
-Copy HTML

-upload images to my server
the 3 .gif files and the .css file appear in the root directory, the .js file is not showing anywhereā€¦
-paste HTML

Now I have the weird watermark button, the link works, but no images.

What am I doing wrong ?
If I check Image Properties in the WYSIWYG editor, the URL is listed as ā€˜images/ebbtcbinsmenu1_0.gifā€™ ????
(Normally, for a plain image, it says: ā€˜http://www.novesi.fr/images/Image/Image/XXXX.JPGā€™)

If I ā€˜browse serverā€™ from within the Image Properties window, I can upload the 3 .gif images this way also, but can only choose one URL. (uploading this way DOES give me the full URL ā€˜http://www.novesi.fr/images/Image/Image/ebbtcbinsmenu1_0.gifā€™ however.

When I check back to all my uploaded files, the images still appear in the root directory AND now also in the /Image folder.
Please help ! This is definiteley my preferred software for menus, but the only one I canā€™t get to work !

Thanks in advance.
Last edited by anitag on Fri Mar 11, 2011 7:52 pm, edited 1 time in total.
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby Aivars » Wed Feb 23, 2011 2:11 pm

Hi and welcome,

I can't see the test button you mentioned in the link you gave.

If you selected relative directory "images" then you need to put the files inside http://www.novesi.fr/images/XXXX.JPG, not http://www.novesi.fr/images/Image/Image/XXXX.JPG; you need to upload all files - images, js and css.

Anyway it seems like you have difficulties with uploading. What software do you use to upload the files?
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Button image not appearing

Postby anitag » Wed Feb 23, 2011 5:30 pm

Thnaks for your quick reply :D

I'm using a program called Shop Application - a webdesigner is doing the site and it comes with the back office software.

I have 2 methods 2 upload:
1. Through "File Manager" where I can upload into the root directory.

* File
* Flash
* Image
* clients
* files_transfered_by_client
* import_files
* mp3
* themes_admin
0407_0438_STST_01_1291915836.jpg
0407_0438_STST_02_1291914317.jpg
ebbtcbinsmenu1_0.gif
ebbtcbinsmenu1_1.gif
ebbtcbinsmenu1_2.gif
0407_0438_STST_02_1291915836.css
etc.

The url of these images is http://www.novesi.fr/images/Image//name.jpg

2. I can upload single images straight into the webpage in the WYSIWYG editor - Image properties (url shows as: images/ebbtcbinsmenu1_0.gif), browse server, upload with "FCKEditor", choose file from desktop, uploads as http://www.novesi.fr/images/Image//Imag ... enu1_0.gif. This is how I managed to see an image, but only in 1 of the 3 coulours.
Images uploaded like this appear in the Image folder in the root directory.

?????
Thanks so much for your help
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby Aivars » Wed Feb 23, 2011 6:12 pm

Ok, it seems like your wedesigner has limited you to /Image directory. Try following:
- select "I will put the files in a *directory* relative.." Directory name: Image <--- instead of images
- upload all files to the File Manager's root

Now, you mentioned that .js file does not get uploaded. It's highly probable your webdesigner has forbidden .js files - you will need to speak to him/her about that and ask to add .js to allowed extensions.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Button image not appearing

Postby anitag » Wed Feb 23, 2011 11:38 pm

Thanks Aivars, really appreciate that, will get on to the tech guys.
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby anitag » Wed Mar 09, 2011 1:16 pm

Hi

You're right - .js files can't be uploaded with the others.

My tech guy keeps telling me to add ALL the files in "source" in the WYSIWYG editor, along with the HTML. Is this possible with EB&MM program?
and for someone with very limited html skills?! :?

Thanks muchly
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby Aivars » Thu Mar 10, 2011 3:52 pm

It's certainly possible, even if against the best practices. I'm not sure why your tech guy want you to do it like this.

Anyway, the basic idea is:
Replace
Code: Select all
<script type="text/javascript" src="mb....js"></script>

with
Code: Select all
<script type="text/javascript">
.... paste contents from the .js file here ....
</script>


and

Replace
Code: Select all
<link rel="stylesheet" href="mb.....css" type="text/css" />

with
Code: Select all
<style>
.... paste contents from the .css file here
</style>


Updating the menu will be more annoying than if you could upload the files (you will need to copy/paste every time).
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Button image not appearing

Postby anitag » Thu Mar 10, 2011 11:55 pm

ok, I did that, but still not seeing the image. I uploaded the images to the root directory AND then also the Image folder in the root directory, I just can't get it to find them.

I know nothing of HTML (thankyou for such clear instructions) which is way I like this program so much.

I think if I can't convince the techy to add .js to allowed extensions, my site shall be button-less....
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby Aivars » Fri Mar 11, 2011 10:46 am

Can you give me a link to page that contains the imageless menu? I'll check what might be missing.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Button image not appearing

Postby anitag » Fri Mar 11, 2011 11:08 am

Just a test button (no links)

thanks
Last edited by anitag on Sat Mar 12, 2011 11:35 am, edited 2 times in total.
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby Aivars » Fri Mar 11, 2011 4:33 pm

I don't see the button. Where is it? :)
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Button image not appearing

Postby anitag » Fri Mar 11, 2011 5:01 pm

The site isn't live yet, but I thought that link would work. Can you see the page at all (lots of remote controlled planes)?

The button is at the top, just under "Accueil Ā» Boutiques Ā» NITRTEK"
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby Aivars » Fri Mar 11, 2011 5:22 pm

I see the planes but not the button or "Nitrek".

Image
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Button image not appearing

Postby anitag » Fri Mar 11, 2011 7:48 pm

Sorry, should have thought - the site's in french - you'll need to click on the french flag, top-left.
anitag
 
Posts: 8
Joined: Wed Feb 23, 2011 1:04 am

Re: Button image not appearing

Postby Aivars » Fri Mar 11, 2011 9:47 pm

The image should be here: http://www.novesi.fr/Image/ebbtcbinsmenu1_1.gif but clicking that link opens a web page instead of picture. I suspect it's your web cms/catalog system that's intercepting all URLs, instead of letting webserver send the file directly.
Ask your tech men which folder they recommend for storing image files.

Btw javascript and css seems to be inlined and working just fine.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia


Return to Easy Button & Menu Maker Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron