Bug: Editor constantly hangs with "Not responding"

Post your questions and problem reports here

Moderator: kfury77

Forum rules
Please try to follow these guidelines. This will help to receive faster and more accurate response.

  • Check the Support section of the corresponding product first. Chances are you will find your answer there;
  • Do not create new topics for already reported problems. Add your comments to the existing topics instead;
  • Create separate topic for each problem request. Do NOT post a number of non-related problem reports in a single topic;
  • Give your topic a meaningful title. Titles such as "A question," "Bug report" and "Help!" provide others no clue what your message is about;
  • Include the version number of the software you are using;
  • This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Wed Jan 09, 2019 12:32 am

@Aivars
It's not bound to a particular file, it is _always_ the case. From my experience, as soon a recurring variable or something similar is written, the lag happens because Code Explorer updates the list immediately. And this updates hinder the coding. As far as I can tell, this is mainly happening with PHP code. I can't say I have experienced this in JS (but I'm not writing JS code as fast :) ) and CSS.
As soon I close the Code Explorer, the lag stops. So, for me, it lloks like the Code Explorer has something to do with it.

Hope this helps a bit.
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Wed Jan 09, 2019 12:35 am

pmk65 wrote:Check the forum rules:
This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

If you want a fast result, contact support. ;)


Look at the Board index: Board index ‹ Web Code Editors - HTMLPad / Rapid CSS / Rapid PHP / WeBuilder ‹ HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support
Check the last word. Any more explanations needed?

I try to help solve a problem here.
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Re: Bug: Editor constantly hangs with "Not responding"

Postby pmk65 » Wed Jan 09, 2019 12:52 am

Hans Meiser wrote:
pmk65 wrote:Check the forum rules:
This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

If you want a fast result, contact support. ;)


Look at the Board index: Board index ‹ Web Code Editors - HTMLPad / Rapid CSS / Rapid PHP / WeBuilder ‹ HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support
Check the last word. Any more explanations needed?

I try to help solve a problem here.


You are still not reading the information in the "forum rules" (The text in the read box in top of the page). That's why I tried to help you, but I guess you missed that as well. :D
There are 10 types of people in the world: Those who understand binary and those who don't.
User avatar
pmk65
 
Posts: 612
Joined: Sun Dec 20, 2009 9:58 pm
Location: Copenhagen, Denmark

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Wed Jan 09, 2019 3:53 pm

pmk65 wrote:You are still not reading the information in the "forum rules" (The text in the read box in top of the page). That's why I tried to help you, but I guess you missed that as well. :D

It seems you don't get the fact, that I'm not seeking "an official customer support helpdesk". Simply because it is obviously not a single user problem.
And since you mentioned my posting in your #1 post it should be obvious that I'm just trying to help the support with my infos in hope to get rid of this bug. And again, this is the HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support, so all I'm asking for is a bit less delay in an open problem solving progress thread. Of course as time allows for the devs.
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Re: Bug: Editor constantly hangs with "Not responding"

Postby Aivars » Wed Jan 09, 2019 4:16 pm

Since you mentioned variables, try removing those from the Code Explorer (Code Explorer toolbar -> Options -> uncheck List Variables). Does that help?

When exactly does the slowdowns occur? When you're typing or when you're clicking? Because as far as I can tell, Code Explorer only gets refreshed on clicks, not when you're just typing code, so it should not affect anything. I would really appreciate a lot more details on this.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2311
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Wed Jan 09, 2019 5:43 pm

Aivars wrote:Since you mentioned variables, try removing those from the Code Explorer (Code Explorer toolbar -> Options -> uncheck List Variables). Does that help?

Great tip, haven't noticed this option before. I will try this option next time, because of this issue till now I had CE always turned off.

Aivars wrote:When exactly does the slowdowns occur? When you're typing or when you're clicking?

When typing. Hence the annoyance.

Aivars wrote:Because as far as I can tell, Code Explorer only gets refreshed on clicks, not when you're just typing code, so it should not affect anything. I would really appreciate a lot more details on this.

Strange, because I notice CE refreshing/flickering when I type. Mainly when a new variable is written or a existing one is changed (what is obvious for a refreshing list) and then "cursored away". Meaning using the arrow keys to navigate away.
I will try to further gather some more details and will post them here.

Thanks for the replies.
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Fri Jan 11, 2019 12:44 pm

OK, did some long coding yesterday, all mixed files (HTML/PHP, PHP, CSS, JS) with CE open and the option "List variables" off.
There was no noticeable lag, only a few times, but I guess that was from auto complete. I then extended this from 200ms to 1000ms. All in all it was very smooth again.
What I also noticed, that it lags sometimes in a CSS file, when I write a property. Something's happening after writing a : that triggers a system audio "ding" and the next character is not taken. I don't know if this is because I'm typing rather fast, but it is annoying as well, but not as much.

Explanation:
I write my properties like so:
Code: Select all
color: #FFFFFF

When this lag happens, this comes out:
Code: Select all
color:#FFFFFF
      ^- missing space and audio "ding"

I'm not sure if this is because of auto complete, because it happens not always. Can't say on which properties, as I never really payed attention when I'm writing styles because of thinking on the task.

But I hope this is helpful in a way.
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Re: Bug: Editor constantly hangs with "Not responding"

Postby Aivars » Fri Jan 11, 2019 1:31 pm

Can you next time you get the "ding" in CSS file, just Ctrl+A and send me everything, letting me know the line that the cursor was at? I'll try to reproduce it on my computers.

P.S. Do you have Inspector pane open?
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2311
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Fri Jan 11, 2019 3:58 pm

Aivars wrote:Can you next time you get the "ding" in CSS file, just Ctrl+A and send me everything, letting me know the line that the cursor was at? I'll try to reproduce it on my computers.

Do you really need the whole file? Isn't it sufficient to take notes on the properties on which it happens? Just asking because a few of my CSS file are a little bigger.

Aivars wrote:P.S. Do you have Inspector pane open?

No. Open are:
Code Explorer File Explorer Messages, PHP debugger and Library. All except Library are placed on the secondary monitor.

Talking about the Library, I want to take the chance to say thanks for the drag'n'drop support. Makes sorting much more pleasing now. :)
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Re: Bug: Editor constantly hangs with "Not responding"

Postby Aivars » Fri Jan 11, 2019 5:05 pm

Yes, the whole file. It's not guaranteed that it's not something earlier in the file in combination with the selector that you're working on that together cause the microfreeze. You can copy it to some pastebin as private paste and PM me the link.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2311
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Sat Jan 12, 2019 12:35 am

OK, I will see what I can do.

What I have done today just for information:
Holding the dash key - and let the row fill up. The dashes are drawn, but stop for a moment after a rather fixed number of characters, around 42 or so. Sometimes, when beginning a new line and pressing dash, it stops earlier, but then the stops come at an equal length again.
Illustration:
Code: Select all
------------------------------------------------------------------------------------------------------
short stop                      -^                                 -^   etc.

Normally, I would expect that the dashes are drawn continuously without stops.
I don't know if this is a normal behavior, just wanted to let you know.
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Re: Bug: Editor constantly hangs with "Not responding"

Postby Aivars » Sat Jan 12, 2019 3:36 pm

Can you test something for me? Try closing File Explorer, go to menu Options -> Preferences and uncheck Enable Crash Recovery, restart the editor and try the dash thing again.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2311
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Bug: Editor constantly hangs with "Not responding"

Postby Hans Meiser » Sun Jan 13, 2019 12:45 pm

Aivars wrote:Can you test something for me? Try closing File Explorer, go to menu Options -> Preferences and uncheck Enable Crash Recovery, restart the editor and try the dash thing again.

OK, tried it and no stops happened. But, oddly enough, after turning back on, there where also no stops. I did this on a new opened RapidPHP Editor. When I first tested this, I had some hours of coding behind me.
Could this be a memory thing?
Hans Meiser
 
Posts: 50
Joined: Tue Aug 12, 2014 5:01 pm

Previous

Return to HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support

Who is online

Users browsing this forum: No registered users and 5 guests

cron