Configure WeBuilder/Rapid PHP with AMPPS & xdebug

Post your questions and problem reports here

Moderator: kfury77

Forum rules
Please try to follow these guidelines. This will help to receive faster and more accurate response.

  • Check the Support section of the corresponding product first. Chances are you will find your answer there;
  • Do not create new topics for already reported problems. Add your comments to the existing topics instead;
  • Create separate topic for each problem request. Do NOT post a number of non-related problem reports in a single topic;
  • Give your topic a meaningful title. Titles such as "A question," "Bug report" and "Help!" provide others no clue what your message is about;
  • Include the version number of the software you are using;
  • This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

Configure WeBuilder/Rapid PHP with AMPPS & xdebug

Postby IceTater » Sat Nov 29, 2014 1:11 am

Configure WeBuilder with AMPPS & xdebug


Summary from the AMPPS website: http://www.ampps.com/blog/how-tos/installing-xdebug-for-all-php-versions-in-ampps-for-windows-1273.html

1) Download desired xdebug version (dll) here, probably one of the TS versions:
http://xdebug.org/download.php

2) Put it in the appropriate /Ampps/php/ext directory. For example, for php-5.5, you'd download

php_xdebug-2.2.6-5.5-vc11.dll

to your Ampps directory, probably C:/Ampps/php-5.5/ext

3) Then rename the file

php_xdebug.dll

Do this for each version of php for which you want to enable debugging. You may need to set Windows permissions for xdebug so that it won’t be blocked from loading.

4) In php.ini, put the following line at the end of the file (for php 5.4 and higher):

zend_extension="{$path}\php\ext\php_xdebug.dll"

5) Check that xdebug is installed. In your brower, bring up:

http://localhost/ampps/

and under "Info" click on PHP Info. php_xdebug will [url]not[/url] show up in the AMPPS PHP extension list.

6) From within WeBuilder, go to the Options menu:

Options ➞ Preferences ➞ External Tools➞ PHP Settings and put in the path & filename to your PHP executable.
IceTater
 
Posts: 8
Joined: Sat Nov 29, 2014 1:00 am

Return to HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron