Code intelligence works intermittently

Post your questions and problem reports here

Moderator: kfury77

Forum rules
Please try to follow these guidelines. This will help to receive faster and more accurate response.

  • Check the Support section of the corresponding product first. Chances are you will find your answer there;
  • Do not create new topics for already reported problems. Add your comments to the existing topics instead;
  • Create separate topic for each problem request. Do NOT post a number of non-related problem reports in a single topic;
  • Give your topic a meaningful title. Titles such as "A question," "Bug report" and "Help!" provide others no clue what your message is about;
  • Include the version number of the software you are using;
  • This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

Code intelligence works intermittently

Postby ToXS » Mon Jan 04, 2016 4:40 am

WeBuilder version 13.5 (13.5.0.169) on Windows 10 x64

Auto completing tags works but when I tap space and start typing “class” sometimes a dropdown will open and sometimes it won’t. After I type the = sign a dropdown will usually open with my selectors but not always. Also whenever I go back and change or add any classes that I’ve given a tag, then the same thing happens, sometimes I get a dropdown and sometimes I don’t. It isn’t just “class” it will happen with any attribute.
ToXS
 
Posts: 3
Joined: Mon Jan 04, 2016 4:11 am

Re: Code intelligence works intermittently

Postby Aivars » Thu Jan 07, 2016 1:09 pm

Take a look at menu Options -> Preferences -> Text Editor -> Auto Complete. You probably need a much smaller delay. Also note that you can trigger auto-complete at any time by pressing Ctrl + Space.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2374
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Code intelligence works intermittently

Postby ToXS » Fri Jan 08, 2016 12:29 am

Thank you. I cut it back to 250 ms and it works fine now.
ToXS
 
Posts: 3
Joined: Mon Jan 04, 2016 4:11 am


Return to HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron