WeBuilder 2016 crashes when opening F4 Library Panel

Post your questions and problem reports here

Moderator: kfury77

Forum rules
Please try to follow these guidelines. This will help to receive faster and more accurate response.

  • Check the Support section of the corresponding product first. Chances are you will find your answer there;
  • Do not create new topics for already reported problems. Add your comments to the existing topics instead;
  • Create separate topic for each problem request. Do NOT post a number of non-related problem reports in a single topic;
  • Give your topic a meaningful title. Titles such as "A question," "Bug report" and "Help!" provide others no clue what your message is about;
  • Include the version number of the software you are using;
  • This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

WeBuilder 2016 crashes when opening F4 Library Panel

Postby trishahdee » Thu Nov 10, 2016 3:13 pm

WeBuilder 14.2.0.186
Win 10, 64bit

I have a Library of code setup so when I hit F4 the right panel opens up to the Library. This has worked fine for years. Now when I use the F4 key there is a delay (which usually happened the first time I open it) and then it crashes and wants to send a report or restart, etc.

This problem was happening off and on for several months but just became constant the last few days. Today, I did update to the latest version today with same results. I even tried using WeBuilder 2015 and got the same problem.

Everything else seems to work fine. The few times I've been able to keep hit "continue program" I was able to get the piece of code from the library to the file and save it but had to restart the program. As long as I don't try to use the F4 key all works as expected.

Any help will be greatly appreciated as this is impacting my workflow.
"It doesn't matter where we come from, what we've done or suffered, or even if we make a difference. We live as though the world was what it should be, to show it what it can be." ~ Angel, Season 4, Episode 67, "Deep Down"
User avatar
trishahdee
 
Posts: 26
Joined: Thu Jul 10, 2008 1:02 am

Re: WeBuilder 2016 crashes when opening F4 Library Panel

Postby Aivars » Thu Nov 10, 2016 3:31 pm

I've received your crash report, it says "Not enough storage available", which means that either something is wrong with PC or something unexpected is going on with WeBuilder resources. I'm not sure how to debug this, but we could try the following:
- go to menu Options -> Export Settings and send me the exported settings (privately)
- open in Windows Explorer %appdata%\Blumentals - zip and send me WeBuilder folder (privately)
After you send me both files I'll try to reproduce your environment locally and perform some tests.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2254
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: WeBuilder 2016 crashes when opening F4 Library Panel

Postby trishahdee » Thu Nov 10, 2016 7:34 pm

Thank you so much for the help and the quick reply. I have PM'd you the information you requested.
"It doesn't matter where we come from, what we've done or suffered, or even if we make a difference. We live as though the world was what it should be, to show it what it can be." ~ Angel, Season 4, Episode 67, "Deep Down"
User avatar
trishahdee
 
Posts: 26
Joined: Thu Jul 10, 2008 1:02 am

Re: WeBuilder 2016 crashes when opening F4 Library Panel

Postby Aivars » Mon Nov 14, 2016 7:03 pm

What is the fastest way to get it to crash? I've reproduced your environment but just pressing F4 many times doesn't do it. I don't even see memory usage going up.

Does it happen for any files/file types/projects or only particular ones? If you make an empty project (in an empty folder or a folder containing only a few files), can you also get it to crash in the same way?
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2254
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: WeBuilder 2016 crashes when opening F4 Library Panel

Postby trishahdee » Mon Nov 14, 2016 8:07 pm

Over the weekend, Win 10 did an update and after the update I was able to use the F4 key a few times and then it gave me the "thinking wheel" and eventually crashed and had to restart. After that it crashed more than it worked.

I did as you suggested and the F4 key works every time. I only have two files open for one project.

As I'm usually working on several projects at a time I will have files from 4, 5 or more projects open in WeBuilder at one time. This can be a lot of files. So maybe that has been the problem? I've been using this editor for at least 8 years and this is the way I always work and I have never had this problem before.

I did wait until the last week in July to do the free upgrade to Win 10 and this problem definitely happened after that but I can't say I noticed it immediately after the upgrade to Win 10 from Win 7. But maybe there was a recent update they did that caused the problem and then this last update fixed a part of it? Just shooting in the dark on that one.

I'll keep working with it and see if the number of open files makes a difference going forward. I'll report back if the problem reoccurs.
"It doesn't matter where we come from, what we've done or suffered, or even if we make a difference. We live as though the world was what it should be, to show it what it can be." ~ Angel, Season 4, Episode 67, "Deep Down"
User avatar
trishahdee
 
Posts: 26
Joined: Thu Jul 10, 2008 1:02 am

Re: WeBuilder 2016 crashes when opening F4 Library Panel

Postby Aivars » Mon Nov 14, 2016 8:13 pm

I usually have 20 files open, so it's not likely that 4-5 open files affects this. Maybe you should try to reinstall WeBuilder. Uninstall, reboot Windows to ensure everything is unloaded and de-cached, then reinstall.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2254
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia


Return to HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support

Who is online

Users browsing this forum: No registered users and 1 guest