Three small bugs

Post your questions and problem reports here

Moderator: kfury77

Forum rules
Please try to follow these guidelines. This will help to receive faster and more accurate response.

  • Check the Support section of the corresponding product first. Chances are you will find your answer there;
  • Do not create new topics for already reported problems. Add your comments to the existing topics instead;
  • Create separate topic for each problem request. Do NOT post a number of non-related problem reports in a single topic;
  • Give your topic a meaningful title. Titles such as "A question," "Bug report" and "Help!" provide others no clue what your message is about;
  • Include the version number of the software you are using;
  • This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

Three small bugs

Postby pmk65 » Tue Mar 21, 2017 7:42 pm

Wrong encoding shown if document is modified outside WeBuilder.
1) If you in the editor, save a document in "UTF-8" format.
2) Modify the document using another editor, and save it as "ANSI".
3) Go back to WeBuilder and select the Tab with the document.
4) WeBuilder now asks if you want to load the updated version. (Say yes.)
5) New version of document is now in editor, but the encoding displayed in statusbar still shows the encoding as "UTF-8" and not "ANSI"
(Closing the document and reopening it, will display the correct encoding)

Also if I in a plugin do a Script.Message(_t(Document.Encoding)) when the content of the editor is modified and set the document encoding to ANSI.
Then if I type standard latin characters, it shows the value "0" as expected. But as soon as I enter a non-latin character, the document encoding changes to "2" (UTF-8 without BOM). And here the statusbar still shows the encoding as "ANSI".
Saving and closing the document and then reopening it, shows the encoding is now UTF-8.


File Explorer shows false "fold/unfold" buttons.
If a folder contains a .ZIP file, WeBuilder will display the folder as if it had subfolders. (Showing the +/- icons, but they have no effect when clicking)


Convert Special characters to Entities
When editing CSS, the "Convert Special Chars to Entities" is not useful. As in CSS you don't use "HTML Entities", but "CSS Entities".

Running "Convert Special Chars to Entities" on this CSS selector:
Code: Select all
.test {
   content: "© copyright";
}


Will produce this invalid code:
Code: Select all
.test {
   content: "© copyright";
}


The correct code should be:
Code: Select all
.test {
   content: "\00A9 copyright";
}
There are 10 types of people in the world: Those who understand binary and those who don't.
User avatar
pmk65
 
Posts: 346
Joined: Sun Dec 20, 2009 9:58 pm
Location: Copenhagen, Denmark

Return to HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron