RapidPHP 2018 (15.0.0.199) requires PHP 5.6 minimum?

Post your questions and problem reports here

Moderator: kfury77

Forum rules
Please try to follow these guidelines. This will help to receive faster and more accurate response.

  • Check the Support section of the corresponding product first. Chances are you will find your answer there;
  • Do not create new topics for already reported problems. Add your comments to the existing topics instead;
  • Create separate topic for each problem request. Do NOT post a number of non-related problem reports in a single topic;
  • Give your topic a meaningful title. Titles such as "A question," "Bug report" and "Help!" provide others no clue what your message is about;
  • Include the version number of the software you are using;
  • This is not an official customer support helpdesk. If you need a prompt and official response, please contact our support team directly instead. It may take a while until you receive a reply in the forum;

RapidPHP 2018 (15.0.0.199) requires PHP 5.6 minimum?

Postby sootsnoot » Fri Apr 13, 2018 5:50 am

This is largely copied from a reply I made to the announcement of RapidPHP 2018 http://forums.blumentals.net/viewtopic.php?f=15&t=7417#p25952
Since I consider it a bug, and would like a reply, I thought it would be better to post it as a new topic.

Aivars wrote:I think you will be better off contacting the support here https://www.webuilderapp.com/support-contact.php. We will need to find out info about your configuration to try to figure out what the problem could be.

To me, I suspect than PHP version might be at fault. Go to menu Options -> Preferences -> PHP Settings and make sure that Path to php.exe is set to PHP version 5.6 or newer. You can simply change it to C:\ProgramData\Blumentals\phpxdebug\php563\php.exe - that's the version that's included with WeBuilder and Rapid PHP 2018.


I'm using PHP version 5.4.34, and have the path to the php.exe for it set correctly, but get this error with RapidPHP 2018. Formatting worked fine with RapidPHP 2016. I didn't see anything in the release notes saying that RapidPHP 2018 requires the use of php 5.6 or newer! I'm not in a position to upgrade the version of PHP I'm using!

Indeed, setting menu Options -> Preferences -> PHP Settings -> Path to C:\ProgramData\Blumentals\phpxdebug\php563\php.exe does allow formatting to work. But won't that cause syntax checking and possibly other features to differ from the PHP version I'm using in production?
sootsnoot
 
Posts: 22
Joined: Sun Feb 24, 2013 4:30 am

Re: RapidPHP 2018 (15.0.0.199) requires PHP 5.6 minimum?

Postby Aivars » Fri Apr 13, 2018 8:06 am

To support formatting code that uses the new PHP 7 versions, we now require php.exe configured to PHP 5.6 for the formatter to work. Lots of people need to format their PHP7 code so we didn't have much choice. There are not that many changes between PHP versions 5.4 and 5.6 (even with PHP 7 although it has a bit more changes it's still backwards compatible) to need to worry about syntax changes and if you don't purposely use newer PHP features, you're fine. So you can just leave PHP 5.4 for your work/webserver/preview environment and use C:\ProgramData\Blumentals\phpxdebug\php563\php.exe for path to php.exe in your Rapid PHP settings.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 2254
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: RapidPHP 2018 (15.0.0.199) requires PHP 5.6 minimum?

Postby sootsnoot » Fri Apr 13, 2018 7:36 pm

Okay, thanks, I was hoping that would be true, but it was pretty jarring to see the formatter just fail with no explanation. Maybe a good idea to change the message to give an explicit clue about this. And/or document it as a change, with your explanation that the version requirement for the formatter won't affect syntax checking or other features, such that the product is still fine for editing code written for earlier versions.
sootsnoot
 
Posts: 22
Joined: Sun Feb 24, 2013 4:30 am


Return to HTMLPad / Rapid CSS / Rapid PHP / WeBuilder Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron