Auto Update Woes

Post your questions and problem reports here

Auto Update Woes

Postby bobmillen » Tue Feb 03, 2015 7:22 pm

Hi,
I have the demo/free version of SSF 6 to evaluate. It was obtained a couple of months ago so may have expired?? Anyway, I'm trying to check the autoupdate facility and have the following:
A sharepoint/mysite URL with 4 files loaded
SS.XML, 1.jpg, 2.jpg, 3.jpg

Creating a new project and using Developer tab, I point to the XML file, and click 'Verify' - but get an access violation. the URL I use (see below) is fine (it works in IE8 directly). I'm thinking two possibilities could be causing the Access Violation:
1. The demo software has expired or doesn't support auto-update
2. SSF can only handle HTTP, and not HTTPS?

The XML is below.
<items>
<item>
<command>add</command>
<url>https://mysite.com/personal/Test/1.jpg</url>
</item>
<item>
<command>add</command>
<url>https://mysite.com/personal/Test/2.jpg</url>
</item>
<item>
<command>add</command>
<url>https://mysite.com/personal/Test/3.jpg</url>
</item>
</items>

Any help gratefully received.
bobmillen
 
Posts: 3
Joined: Tue Feb 03, 2015 7:09 pm

Re: Auto Update Woes

Postby Aivars » Tue Feb 03, 2015 8:58 pm

Yes, HTTPS is not supported but instead of access violation it should say that could not download XML file. Is it possible that Sharepoint adds additional data/text to XML? Your XML file works as-is in Screensaver Factory 6 according to my tests.
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 1958
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia

Re: Auto Update Woes

Postby bobmillen » Wed Feb 04, 2015 11:33 am

Thanks for confirming so quickly . Yes it did say the XML could not be downloaded... and then gave the reason as Access violation :o

I'll find another way to check this using http only.

Many Thanks
bobmillen
 
Posts: 3
Joined: Tue Feb 03, 2015 7:09 pm

Re: Auto Update Woes

Postby bobmillen » Wed Feb 04, 2015 7:15 pm

Ok - now trying from an http site (after updating the XML to reflect this), but still not working apparently. The full error message I'm getting is:

Specified URL does not contain a valid XML file.
Unable to download XML file
Access Violation at address 00515A5C in module 'scrfact.exe'. Read of address 0000001C

I can access the XML file fine on the webserver using a browser, and it also is not being amended. I'm running Windows 7 x64.

I re-downloaded the software (6.6) and reinstalled (just in case of corruption) - same result.

I captured what was going on using Sysinternals ProcMon, and it actually looks fine - read some regkeys, access the server (which reported success) etc. The only thing out of place was it attempted to read a file in ProgramData/Blumentals, and the folder and file is not there - but this might be normal.

I wondered if the access to the server was going through our proxy server and this might be a problem - so I added it locally to proxy exceptions.

I've checked Event Viewer, firewall logs etc - and nothing.

I'm stumped - any ideas?
Thanks
bobmillen
 
Posts: 3
Joined: Tue Feb 03, 2015 7:09 pm

Re: Auto Update Woes

Postby Aivars » Sun Feb 08, 2015 6:05 pm

Is the XML file on a public URL so that I could take a look?
Blumentals Software Programmer
User avatar
Aivars
Blumentals Software Developer
 
Posts: 1958
Joined: Thu Aug 22, 2002 1:40 pm
Location: Latvia


Return to Screensaver Factory Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron